Announcement

Collapse
No announcement yet.

Contact problems with FTDNA

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Contact problems with FTDNA

    I've been trying to change a FTDNA order for a week but I can't submit a ticket/open a request - as the submit ticket button doesn't seem to be working. (And the customer services operators aren't answering my emails.) Is the site/customer services disabled as a result of the weather problems?

    Thanks

  • #2
    The submit button hasn't worked for months, at least for Firefox users. The shopping cart probably still isn't working either.

    If you are using Firefox, try a different browser and see if it works.

    They just don't seem to care. Or they don't know how to fix anything.

    Comment


    • #3
      The problem may be on your end. I use Firefox and have not experienced this issue ever. I just tried it right now and I can press on those buttons just fine. Maybe your Firefox is outdated.

      What OS (operating system) are you on? Windows or Mac and what version of it. Open a Firefox browser. Click on the top right button to open a menu. Click on Options. Then on the left side click on Advanced. Then click on Update. Do you have automatically install updates set? If you click on Show Update History, it will show a list of updates that have been installed. The latest for me shows version 55.0.3.

      Comment


      • #4
        Thanks for the replies.

        I'm using Windows 10 and Chrome. But I have also tried Edge and Waterfox (64 bit browser) - and have found that the submit button does not work in any of these three browsers. (They are all up to date.)

        But I'm also not getting any response to my emails ... I was in conversation with a customer services operative but they suddenly ceased responding, although I was in the middle of changing an order! So I don't know what to do, to be honest

        Comment


        • #5
          My browser is up to date. I'm still using Windows 7. I don't know if that's the problem, but I noticed the shopping cart issue already over a year ago.

          Comment


          • #6
            Strange. Perhaps there is an add-on or some other piece of software interfering with some of the functionality. Do any of you have anti-virus or anti-malware software that you use for the internet. Maybe some program is blocking some aspect of the browser that it finds to be unsafe. I'm on Windows 8.1. Do you have some sort of ad-blocker? That could be another possibility. Some other software that you may have that I do not or that I do but has been updated.

            Can you walk me through the shopping cart issue to make sure we are on the same page. If you add a new test, I assume pressing the proceed to checkout button does not work for you? Does it react like it is not a button or like the button does not change anything when pressed?

            Comment


            • #7
              I do use an ad blocker and Norton anti-virus. It's been a while since I purchased a kit. I bought one around Aug 2016 and another a few months later. If I remember correctly, I had trouble getting the address of the person I was purchasing the kit for to save, and when I purchased, I got some message that there was a problem and the purchase didn't go through. Despite that, it did go through, as I received emails on both occasions confirming the purchases. It was a good thing I checked my mailbox before a second attempt.

              Comment


              • #8
                Then perhaps that case of the issue may have been solved since then. Can you try it right now without actually completing the purchase to see if you run have that issue or can it only be replicated by finalizing the purchase?

                osullivanbere, when you tried to fill out the contact form, did you make sure to check the box that makes sure you aren't a spambot. I don't think this option appears if you are logged in. Maybe try again? Make sure you fill out everything with the asterisk (*). Were you logged into your kit when you tried to fill out the form?

                Comment

                Working...
                X