No announcement yet.

Unable to select matches

  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to select matches

    For the past 18 hours, the site freezes when I try to select a match (to run in the Chromosome Browser or any other reason). Having been utilizing FTDNA for around 10 years, it's always been glitchy, but lately it is unbearable. Why is it so difficult to make this site work like it is supposed to??

  • #2
    Probably for the same reason Ancestry always has problems with their DNA website.

    I just tried Chromosome Browser and it worked.


    • #3
      I am so fed up with this website. It is almost impossible to access it after 5pm our time as that is when the USA and Australians log on. Then there is the Chromosome Browser with the various shades of blue which I find really difficult to differentiate. The older system was much better. I have complained before but nothing acknowledged.


      • #4
        Chromosome Browser was having issues, for weeks. And weeks. When it began to be fixed, I was told it was working fine for some users and not others, and eventually it was working fine for every other user but me. Or that's what I was told. This was posted in mid October and it is now mid November.


        • #5
          I just selected matches and used Chromosome Browser with no issues.

          Have you tried using a computer belonging to a relative, friend or neighbor?