Announcement

Collapse
No announcement yet.

My Origins not working..

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • My Origins not working..

    My Origins is not loading, anyone else having this problem

  • #2
    Mine is not working either

    Comment


    • #3
      Originally posted by benboy View Post
      Mine is not working either
      7 hours later, kits I have tested ( > 10 ) have myOrigins working perfectly well.

      Mr W

      Comment


      • #4
        Mine keeps saying its pending though everything else is in.

        Comment


        • #5
          Originally posted by TXbama View Post
          Mine keeps saying its pending though everything else is in.
          • Has it ever worked?
          • When did you receive your Family Finder results?


          Mr W

          Comment


          • #6
            question -

            do they send you results in the mail? or do you have to log in to see it?

            how does that work.

            paid a YEAR ago, never got anything back.


            k

            Comment


            • #7
              You have to login for the results. If you took a test, you tend to get an email to notify you when the results are ready. Though the email is sometimes a few days after the results are posted.

              If you did a transfer and then paid to have it unlocked, it shouldn't take a year... not even a month. If this is what you meant, then click on the Customer Support link at the top of this page. Click on "Open a request" in the Support section. Enter your kit number and other info. In the details box explain the issue. They will respond to you through your email. Just reply back through that same email message if you need to respond to them.

              Comment

              Working...
              X