No announcement yet.

Download all segments not working

  • Filter
  • Time
  • Show
Clear All
new posts

  • Download all segments not working

    For more than a month now, I've been unable to download all segments for matches from the Chromosome Browser except for the occasional time when it works. For example, it worked for me once yesterday, then stopped working. I've tried this on four different browsers and two different PCs, rebooted, cleared browser history, made sure none of my settings were blocking the download, etc. I manage a lot of kits and have used this tool for many years with no problem. Now, I have about a dozen kits that posted results in February and more that are still being processed, so this is a huge problem.

    I ran diagnostics on my PC on a few different dates and got these responses:I contacted FTDNA Support on February 17, citing the kit I was working with at the time. I got a reply several days later with a spreadsheet of data for that kit. Since I still couldn't download segments for any other kit, I wrote back to Support and learned that they couldn't download the data either, so they sent the issue to IT. I've checked back with Support three more times, it's still not working, and they can't tell me when it will be fixed. In the meantime, my work is stalled, and the backlog is growing.

    For one project, I needed to get an analysis to the kit owner who was meeting a match in Israel this week, and I ended up downloading 10 batches, each with seven kits of ICW matches, and copying them from the 10 downloaded spreadsheets into one so I could sort and analyze the data. Ugh. The limit of seven matches at a time, even though it's up from five, is ridiculous, but not being able to download all segments is even worse. In fact, it should be possible to click a button to include all matches in an ICW group to download all segments for that group without having to check off each person separately.

    Surely, since the problem with downloading all segments appears to be with the FTDNA website, there must be other users who are running into the same problem. IT should be able to fix this in a few hours at most. What's your experience, and why can't FTDNA fix get the problem right away?

  • #2
    Is this function working for others?


    • #3
      I just tried this.

      I put 7 matches in the Chromosome Browser, clicked on DOWNLOAD SEGMENTS and it worked fine.

      Tried another 7 matches in the Chromosome Browser, clicked on DOWNLOAD SEGMENTS and it worked fine again.

      Don't know what to tell you.


      • #4
        Downloading all segments for all matches is not working for me, either.


        • #5
          My apologies, I misunderstood the problem.

          You want to "DOWNLOAD ALL SEGMENTS" for all matches. I had to search for how to do this.

          My downloaded csv file is 1.061 MB and looks like it has all my matches. So it looks like it works for me.


          • #6
            Several weeks later, and this function is still not working for me. I've been in touch with Support a few more times, and they couldn't get it to work either. And they have no idea when it will be fixed.

            Jimbirk, when did you get your results? Was it some time ago or very recently?

            Occasionally, I can download all segments for older kits, but not for any that have finished processing in the last few months. Even for older kits where I want to get an updated spreadsheet with recent matches, it doesn't work most of the time. I am able to download segments for up to seven people at a time, but that is very tedious when there are hundreds of close and immediate matches, and I'm working with a lot of kits.


            • #7
              Same need, same issue and I couldn't even get support to give me a reason, an answer or a schedule for fixing.


              • #8
                Since I hadn't saved it for my own account in a while, I just tried "Downloading All Segments," from the Chromosome Browser page (without selecting any matches, simply going to the page from the home page). I was able to download the segment list for all my matches, using Firefox "Quantum", v. 60.2.0esr on Mac OS "Sierra," v. 10.12.6.

                I hope the issue that others have reported will be fixed soon.


                • #9
                  worked for me just now.....(Chrome)


                  • #10
                    It's now June. Since February, like lcafarel, the "Download All Segments" basically has become something that works once in a blue moon. It seems to be an issue of the servers being overloaded and the amount of processing required for a person's particular file.

                    People with fewer matches are more likely to have their downloads work. But people such as myself, who have almost 20,000 matches that result in almost 400,000 segment matches have much more trouble. I Iast successfully downloaded my Chromosome Browser Results file using the "Download All Segments" tab on May 7th. But that was one success in maybe 100 attempts.

                    The biggest problem is that the "Download All Segments" button provides no feedback at all other than highlighting when your mouse hovers over it, and briefly darkening once you press it. After that nothing. You wait and wait. For my file, it takes a minimum of a couple of minutes for it to complete … if it completes. After about 10 minutes, I start wondering. So I (like most people would), I wonder if my button press didn't register so I press it again. Who knows what this might do on your servers. Would it interrupt the current process and start another. Or just start a second process. There have been times in frustration that I've pressed the button a dozen or more times, because there's no feedback and I have no idea if the request has been accepted or not. If nothing else, the feedback on this button needs to be improved so that the user knows that the request is processing.

                    The file I get is a 23 MB file with almost 400,000 lines in it. If this is too much for your servers to handle online with everything else it does, maybe you should change this to a batch process like MyHeritage does, and send an email when the result is ready.

                    The issue that Icafarel brought up to start this thread is an important one that has not changed since his posting in February.

                    p.s.: While I was writing this, one of my 6 attempts to download my segment file worked. It took about a half an hour from the time I pressed the button. None-the-less, it does not work all the time (likely when the server is busy) and the feedback issue needs to be addressed.
                    Last edited by lkessler; 7 June 2019, 10:32 AM.


                    • #11
                      Only just learning the ropes here, just done the download which took a few attempts, file is 3.42mb, with 55,800 lines in it. Now I've got to figure out what am I supposed to do with the information.


                      • #12
                        "Download all segments" is just running in a loop for me. After hours, on different PCs, different browsers, different accounts it hasn't once completed the job. I know that it used to work ... any ideas on what is going on here? My latest effort is using Firefox Quantum, which has been running for about 1 hour. I'll leave it running overnight and see if I get a result.