No announcement yet.

Can't view family trees

  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't view family trees

    Is anyone else having trouble viewing your matches' family trees? I keep getting a spinning symbol that goes on forever.

  • #2
    I haven't been able to get the chromosome browser to work today. Nothing appears on it even when I try matches that always worked before. Just tried a tree and got nothing but the spinner.

    And when I click on a match or sort on a category, the page is incredibly slow to load.


    • #3
      It's been super slow for most trees and sometimes fails totally.


      • #4
        Same here, can only view my own tree, managed to view one other family tree a couple of days ago, but all I get now is the never ending spinner.

        As I have only just joined FTDNA this is a big disappointment

        I hope someone is monitoring this forum and can fix this soon.


        • #5
          @Richchad, FTDNA doesn't really monitor the forums (apart from Darren, a customer support specialist, but he can't report everything). You are much better off sending in a help request by using the Customer Support link at the top right of these forum pages, and using the link under the Support heading.

          As for the Chromosome Browser and Family Trees, I am not getting any delays. I just checked, and no problems seeing either. I haven't noticed any problems with them in the recent past. I'm using Safari 9.0.3 on a Mac with OSX 10.9.5.

          Someone in another thread mentioned that perhaps an ad blocker could interfere with scripts used on the FTDNA website. They disabled theirs, and things worked again, but I don't recall if it was the Chromosome Browser or trees.


          • #6
            Thanks for your reply KATM, I have made a request to customer support.

            Incidentally I have tried with ad blocker disabled also tried in Firefox, Chrome & IE11. all give same problem.


            • #7

              I have reported this problem to the engineering team. It seems to be intermittent on my end, with no sure fix to get it to work correctly. I am sorry for this inconvenience.

              Family Tree DNA


              • #8
                Thanks for letting me know Darren.


                • #9
                  Cannot view mtDNA matches GEDCOMs

                  Although I can view the GEDCOMs of my autosomal matches, I am unable to open the GEDCOMs of my mtDNA matches. I've written to the company twice. I also see multiple kits for the same kit. Why can't they fix this?