Announcement

Collapse
No announcement yet.

Group Administrator can not access anything

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Group Administrator can not access anything

    I was a group co-administrator that was upgraded to full administrator but now, not only can I not access what I used to when I was a co-administrator, I am also not able to access anything as administrator. all I can view is my own profile/results etc.

    To make matters worse the original administrator has already downgraded themself to a co-administrator so now we are left with no one that can administrate the group.

    Yet I am receiving emails about matches with a link that's supposed to take me to the administrator's page but only sends me to the login page.

    I am also unable to login using my username and can only login using my kit number. Not sure if this is related to the above problem or if this is another separate issue.

    Finally, after waiting days I can post here in the forum.

    I have tried asking for help using the contact form but it's been days and have yet to receive any response at all.

    I've been part of our surname group since 2006 or 2007. How am I supposed to answer peoples questions about their results if I can not see them?

    If there is anyone at FTDNA that is still willing or able to help please contact me and I'll provide whatever additional info you might need.

  • #2
    Originally posted by Packrat View Post
    I was a group co-administrator that was upgraded to full administrator but now, not only can I not access what I used to when I was a co-administrator, I am also not able to access anything as administrator. all I can view is my own profile/results etc.

    To make matters worse the original administrator has already downgraded themself to a co-administrator so now we are left with no one that can administrate the group.

    Yet I am receiving emails about matches with a link that's supposed to take me to the administrator's page but only sends me to the login page.

    I am also unable to login using my username and can only login using my kit number. Not sure if this is related to the above problem or if this is another separate issue.

    Finally, after waiting days I can post here in the forum.

    I have tried asking for help using the contact form but it's been days and have yet to receive any response at all.

    I've been part of our surname group since 2006 or 2007. How am I supposed to answer peoples questions about their results if I can not see them?

    If there is anyone at FTDNA that is still willing or able to help please contact me and I'll provide whatever additional info you might need.
    I had good results calling when the company help desk first opens in the morning @ 713-868-1438, opens 9 AM Central time. Listen to all the options, one of the options will be for group administrators.

    Comment


    • #3
      Thanks. I may have no other choice.

      Comment


      • #4
        Originally posted by Packrat View Post
        Thanks. I may have no other choice.
        Did you try to recover your administrator password ?

        W. (Mr.)

        Comment


        • #5
          I did the recover password thing and the recover username thing they are both correct. I can login using my kit number and my password but logging in using my username fails.

          Comment


          • #6
            Originally posted by dna View Post
            Did you try to recover your administrator password ?

            W. (Mr.)
            There was a Facebook post that stated part of the email/notification system wasn't working properly and that included password reset/recovery. The suggestion was to call if you were having password issues. The post is about 10-12 days old but it doesn't say that it was ever fixed.

            Comment


            • #7
              The password works just fine. My username does not. I can login using my kit number and password but I can no longer access what I could before as a co-administrator and still can not access anything as administrator. All I can access now is my own kit and info.

              Comment


              • #8
                I did just hear of someone else who cannot get into 3 of their groups..
                SIGH
                Another "known issue"?

                Comment


                • #9
                  At the moment I can access dashboard of either the project or my kit but I can't do anything else. Regardless of what I click on I keep getting the Houston we have an problem message. It appears they are are doing site upgrades or maintenance.

                  Comment


                  • #10
                    I have a kit number and password for my personal kit and a username and password for my projects. Both passwords are different.

                    I have just singed in as admin, signed out and the signed in to my personal kit. No problem with either one.

                    Comment


                    • #11
                      Originally posted by gerlyons View Post
                      There was a Facebook post that stated part of the email/notification system wasn't working properly and that included password reset/recovery. The suggestion was to call if you were having password issues. The post is about 10-12 days old but it doesn't say that it was ever fixed.
                      okay, perhaps that explains my problem today. I have a brand new kit, but did not receive the password by email. I did the password reset twice, but again no email.

                      I'll call the help desk in the morning to recover the password. Thanks for the heads up on this issue.

                      Comment


                      • #12
                        Originally posted by K. L. Adams View Post
                        okay, perhaps that explains my problem today. I have a brand new kit, but did not receive the password by email. I did the password reset twice, but again no email.

                        I'll call the help desk in the morning to recover the password. Thanks for the heads up on this issue.
                        Called the help desk and he confirmed they are having spotty problems with password notifications. They created a new password and I was on my merry way within 5 minutes.

                        Comment

                        Working...
                        X