No announcement yet.

Trouble Ordering

  • Filter
  • Time
  • Show
Clear All
new posts

  • Trouble Ordering

    I'm having trouble ordering new tests for one of my kits. When I select a test and try to check out it says "please select a gender to proceed" but I don't see anywhere to pick a gender.

    I don't have this problem with any of the other kits, am I missing something or is it a glitch?

  • #2
    The gender field is located in the orange box in the middle of the shopping cart. See the screenshot below.


    • #3
      Hi Gugel,
      I don't have the orange box. I switched to the the mt test since gender should be irrelevant but get the same thing.
      I've attached a screenshot.
      Attached Files


      • #4
        I have that problem, as well. I've tried multiple browsers.

        Any solution yet?


        • #5
          Not sure what changed but I was able to complete the order today.


          • #6
            I had a 2nd cousin who tested at Ancestry a couple of months ago. I didn't know her, but I persuaded her to transfer here. She could never get the checkout to work. She tried several times. I tried to get her to call the help desk, but she just decided not to transfer.

            Not good for FTDNA's business and not good for me either, as she is in my brick wall line and might have had some different segments that would have helped me!

            PLEASE forget the fancy stuff and make checkout as simple as possible!!!


            • #7
              Both of you should upload to GEDmatch when it is back up.